Νέα και ειδήσεις από το χώρο της Πληροφορικής, των Τηλεπικοινωνιών και λύσεις σε συχνά προβλήματα

AVG 8 Σφάλμα εγκατάστασης: Registry value is not of a BINARY type

3 Σχόλια

Το AVG τελευταία αρχίζει να κάνει…»νερά»! Ο λόγος τα απανωτά προβλήματα που ανακύπτουν είτε κατά την ενημέρωση της εφαρμογής μέσω Internet (updates) είτε κατά την εγκατάσταση ή/και αναβάθμιση.

Το πιο πρόσφατο που μου έτυχε είναι όταν προσπάθησα να αναβαθμίσω το AVG σε υπολογιστή που είχε προηγουμένως εγκατεστημένη την έκδοση 7.5

Όλα πήγαιναν μια χαρά, απεγκατέστησα το AVG 7.5, κατέβασα την πιο πρόσφατη έκδοση από το site της εταιρείας και ξεκίνησα την εγκατάσταση…

Ξαφνικά, στο τέλος της εγκατάστασης μου πέταξε ένα ωραιότατο παράθυρο με το μήνυμα (πατώντας στο κουμπί Details):

Installation Failed – Error: Registry value is not of a BINARY type

Νέο φρούτο λέω…δεν μπορεί…

Ψάχνοντας για αρκετή ώρα και googlάρωντας ανακάλυψα ότι δεν είναι και τόσο σπάνιο σφάλμα. Το πρόβλημα βρίσκεται σε ένα κλειδί του Μητρώου των Windows όπου εκεί για κάποιο άγνωστο (?) λόγο – κατά τη διάρκεια της εγκατάστασης – ο τύπος των δεδομένων είναι δηλωμένος λάθος.

Το κλειδί ονομάζεται PendingFileRenameOperations και σύμφωνα με το forum της AVG ο τύπος πρέπει να είναι REG_MULTI_SZ ή REG_BINARY.

Το κλειδί βρίσκεται στο: HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Control Session Manager

Ακολουθώντας λοιπόν τις οδηγίες χρηστών στο παραπάνω forum δεν κατάφερα να βρω λύση (είτε διαγράφοντας είτε αλλάζοντας τον τύπο δεδομένων που «δέχεται» το κλειδί).
Τελικά, η λύση ήρθε με λίγη φαντασία και δημιουργικότητα. Έψαξα μερικά επίπεδα πιο πάνω και είδα ότι όχι μόνο στο CurrentControlSet αλλά και Control01 και Control03 υπήρχαν τα αντίστοιχα κλειδιά. Διαγραφή λοιπόν, επανεκκίνηση και…η εγκατάσταση ολοκληρώθηκε!

Advertisements

3 thoughts on “AVG 8 Σφάλμα εγκατάστασης: Registry value is not of a BINARY type

  1. όντως, τώρα τελευταία, πολλά bugs το avg.

    Εμένα, μετά από το update μου αντικατέστησε τον χαρακτήρα παύλα (-) με το λατινικό γράμμα i σε όλο το interface του avg 8.

    μήπως σου έχει συμβεί και σένα ή μήπως έχεις διαθέσιμο κάποιο link για αυτό το πρόβλημα?

    ευχαριστώ εκ των προτέρων!

  2. Δυστυχώς Σπύρο όσο και να έψαξα δεν μπόρεσα να βρω κάτι για τέτοιο bug…

  3. Thanx anyway!

    Ευτυχώς που δεν είναι λειτουργικό, προς το παρόν, το πρόβλημα πάρα μόνο αισθητικό.

Σχολιάστε

Εισάγετε τα παρακάτω στοιχεία ή επιλέξτε ένα εικονίδιο για να συνδεθείτε:

Λογότυπο WordPress.com

Σχολιάζετε χρησιμοποιώντας τον λογαριασμό WordPress.com. Αποσύνδεση / Αλλαγή )

Φωτογραφία Twitter

Σχολιάζετε χρησιμοποιώντας τον λογαριασμό Twitter. Αποσύνδεση / Αλλαγή )

Φωτογραφία Facebook

Σχολιάζετε χρησιμοποιώντας τον λογαριασμό Facebook. Αποσύνδεση / Αλλαγή )

Φωτογραφία Google+

Σχολιάζετε χρησιμοποιώντας τον λογαριασμό Google+. Αποσύνδεση / Αλλαγή )

Σύνδεση με %s